当页导航

Domino 8升级901后报错 HTTP Web Server: IBM Notes 异常 - Entry not found in index

目前是在Windows Server 2008上运行的32位Domino 8,准备升级到Domino 901 64位,从虚拟机上做的测试,发现一些问题。升级步骤:1、覆盖安装在原Domino 8的安装目录2、2.1x:\Lotus\Domino\nfixup names.nsf -F x:\Lotus\Domino\nfixup admin4.nsf -F2.2 x:\Lotus\Domino\ncompa...显示全部

目前是在Windows Server 2008上运行的32位Domino 8,准备升级到Domino 901 64位,从虚拟机上做的测试,发现一些问题。


升级步骤:

1、覆盖安装在原Domino 8的安装目录

2、

2.1

x:\Lotus\Domino\nfixup names.nsf -F

x:\Lotus\Domino\nfixup admin4.nsf -F

2.2

x:\Lotus\Domino\ncompact names.nsf -c

x:\Lotus\Domino\ncompact admin4.nsf -c

2.3

Updall

3 启动服务

原来系统的用户登录进OA 可以正常使用,从管理工具注册一个新用户,登录进OA后

有些模块,比如更改口令的模块显示:HTTP Web Server: IBM Notes 异常 - Entry not found in index

邮箱通过http://***/mail/aa.nsf可以正常登录使用。

4、在控制台输入命令updall,这时再用新用户登录就可以正常使用了,没有报错。

原来的系统一直正常使用的没有报过错误,升级后,新注册用户都要这样updall更新下才行,请问专家这是什么原因。



收起
希望获得:具体解决, 注意事项, 原理分析, 实例参考

6回答

yuxiaoxuyuxiaoxu软件开发工程师 , 上海理想
leejinli赞同了此回答
是不是数据库系统格式也改过了。改过了物理数据或者分布就需要重建索引了。显示全部

是不是数据库系统格式也改过了。改过了物理数据或者分布就需要重建索引了。

收起
 2017-04-10
  • leejinlileejinli(提问者)
    因为我对这方面不是很熟悉,只进行了上面的几步操作,其它的都没有改动过。
    2017-04-13
  • leejinlileejinli(提问者)
    我们公司都是通过web方式访问的,没有使用notes客户端,8.0 的邮箱系统在新的浏览器下使用不正常,火狐或谷歌的都不能用,所以想升级成901版本的。升级完邮箱没问题了,但是原来的OA 却有了上述的问题。
    2017-04-13
  • yuxiaoxuyuxiaoxu(答主) 回复 leejinli(提问者)
    现在绝大多数都针对IE开发的,需要用到一些特性的。全平台支持或者跨浏览器兼容需要做很多工作。不是你升级能解决的。升级也就是定制输出的HTML DOCTYPE头。
    2017-04-14
qq33025135qq33025135其它 , 失业中。。。
中国航天,这个单位牛!祖国的未来。Load compact 数据库目录 -BLoad updall 数据目录 -r试试这两个命令,看看吧。显示全部

中国航天,这个单位牛!祖国的未来。

Load compact 数据库目录 -B

Load updall 数据目录 -r

试试这两个命令,看看吧。

收起
 2017-04-13
leejinlileejinli数据库管理员 , 中国航天
Load compact 数据库目录 -BLoad updall 数据目录 -r数据库目录和数据目录是什么?能举个简单的例子吗数据目录:C:\\lotus\\domino\\data\\  ?数据库目录 是OA程序所在的文件夹吗?C:\\lotus\\Domino\\data\\OA\\ ?...显示全部

Load compact 数据库目录 -B

Load updall 数据目录 -r

数据库目录和数据目录是什么?能举个简单的例子吗

数据目录:C:\\lotus\\domino\\data\\  ?

数据库目录 是OA程序所在的文件夹吗?C:\\lotus\\Domino\\data\\OA\\ ?

收起
 2017-04-13
leejinlileejinli数据库管理员 , 中国航天
有个MailServer 域 @DbLookup("":"cache";"":"names.nsf";"($VIMPeople)";@Name([Abbreviate];@UserName);"MailServer")应该是OA系统里的这个程序出的问题,我从Designer 查到这个代码,在Notes中预览报:域MailServer :视图中未找到条目或未建立视图索引...显示全部

有个MailServer 域

@DbLookup("":"cache";"":"names.nsf";"($VIMPeople)";@Name([Abbreviate];@UserName);"MailServer")

应该是OA系统里的这个程序出的问题,我从Designer 查到这个代码,在Notes中预览报:域MailServer :视图中未找到条目或未建立视图索引

收起
 2017-04-13
leejinlileejinli数据库管理员 , 中国航天
谢谢大家回复,每次新添用户后,执行下 load updall 就没问题了,我在找找原因,肯定和索引有关系。显示全部

谢谢大家回复,每次新添用户后,执行下 load updall 就没问题了,我在找找原因,肯定和索引有关系。

收起
 2017-04-14
qq33025135qq33025135其它 , 失业中。。。
($VIMPeople)重建一下这个视图的索引,或者打开设计保存一下。实在不行,就删除再从好的库中拷贝一个过来。有一种情况是设计元素坏了。但根据目前你反应的信息,应该只是索引问题,视图有个自动更新索引的设置,你看看。我这里遇到你类似的情况,手动重建一下视图索引问题就可以解决...显示全部

($VIMPeople)

重建一下这个视图的索引,或者打开设计保存一下。实在不行,就删除再从好的库中拷贝一个过来。有一种情况是设计元素坏了。但根据目前你反应的信息,应该只是索引问题,视图有个自动更新索引的设置,你看看。我这里遇到你类似的情况,手动重建一下视图索引问题就可以解决。但是需要根据你那里的具体情况具体分析了。

收起
 2017-04-18

撰写回答

提问者

leejinli数据库管理员, 中国航天
发布8
回答7